Блог Яндекс.Браузера

Первые скриншоты из Яндекс.Браузера для Linux

Удалённый пользователь
14 июля 2014, 17:24

Недавно некоторые из наших читателей просили поделиться подробностями о готовящейся версии Яндекс.Браузера для Linux. Сегодня мы покажем первые скриншоты. Другие детали раскрывать пока не будем, но скажем, что браузер под эту платформу существует (и даже запускается), однако публичный запуск следует ожидать не раньше, чем будет завершена стабилизация сборки и исправлены основные проблемы.

 

Хочется отдельно сказать, что создание Яндекс.Браузера для Linux это не просто "пересборка" текущего кода под другую операционную систему, а полноценная разработка. И основные проблемы тут не на уровне движка, а в доработке компонентов и функций, многие из которых достаточно сильно зависят от конкретной платформы.

Если вы хотите получить уведомление о публичной доступности первой версии, то можете подписаться здесь.

41 комментарий
Подписаться на комментарии к посту
Мастер Груша х_х
14 июля 2014, 17:44

Приятно видеть определенные телодвижения в сторону Linux, особенно от Яндекса.

Спасибо!

 

P.S. Осталось только дождаться полноценного клиента от ваших коллег из команды Яндекс.Диска :)

А чем он не полноценный? тем что консольный? Я им пользуюсь -- работает стабильно и "тихо" без лишних окошек и вопросов. Мне нравится: один раз запустил и забыл что это такое, а он работает, работает...

Обрадовали! Спасибо за труд. Буду ждать.

Отлично! Сейчас на linux пользуюсь chromium, многих фишек не хватает. Хром использовать не хочется.

Круууто!!!!)!)

Почему стрелка и значок обновления такие некрасивые?

Это стандартные иконки ubuntu - humanity

Почему у вас в форме подписаться не стоит автоматом email? Обычно стоит и это очень удобно, просто нажал на кнопку и всё)

 

а про Я.Браузер, верим, надеямся, ждём)

 

Куранов Александр
15 июля 2014, 03:11
Я много читаю технической англоязычной документации в сети, поэтому для меня, одним из приоритетов остаётся поддержка встроенного перевода контента (где при выделении слова, web-браузер автоматически предоставляет перевод).

У меня он часто не может двух слов перевести. А то и одно

напишите в поддержку

Они поддержат меня?

А смысл?
теперь и я начал понимать чувства ожидающих, особенно после переезда на Убунту. главное, есть резервный акк у Гугла, где есть почти все закладки и пароли.

ждём.

Отлично!
Ждем сборок и будем тестировать :)

 

Надеюсь, что установка будет не только у debian-типов дистрибутивов. У меня ROSA -- "потомок" Mandriva (rpm пакеты) Хочется надеятся, что русские дистрибутивы не обойдете стороной :) И еще вопрос: можно ли в дальнейшем увидеть ваш браузер непосредственно в репозитории?

Оценивается популярность систем. Не думаю, что под конкретные малопопулярные дистрибутивы будет специальная адаптация. 

Если будет добавление репозитория (как в Яндекс.Диске), то сделайте пожалуйста проверку на дистрибутив такую же, как собственно в Яндекс.Диске.

 

А то например в Maxthon/Google Chrome в Альт Линуксе устанавливается с диким бубном из-за того, что установщики думают что это Red Hat (из-за наличия файла /etc/redhat-release) и проверяют прямо в RPM установлен ли ключ командой (rpm -q KEY), что приводит к зависанию установки в этой точке, т.к. база RPM при этом заблокирована.

 

А вот в Яндекс.Диске проверка сделана замечательно, в следствие чего в Альт Линуксе RPM-ка сайта корректно устанавливается и работает (репозиторий правда не добавляется,  но всё же). :)

Ебилды сделайте, не забудьте гентушников! ;-)

Я считаю, что в этом случае надо как-то привлечь мантейнеров дистрибутивов, или пустить исходный код для сборки и адаптации под конкретные дистры. Я общаюсь с разработчиками ROSA Laboratory -- могу сообщить им решение Яндекс на этот счет.

Подумаем, но у нас нет планов на публикацию исходного кода сейчас, это бы отняло огромные ресурсы. 

Понятно! Спасибо за ответ! очень буду ждать!

Тогда сделайте сборку под Федору (сам Росой пользуюсь) еще, а то про rpm совсем забудите. И в лицензии разрешите пересборку пакета, как в Steam.

 

(+1)(+1)(+1)

:-):-):-)

 А в Яндекс-браузере будет ли поддерживаться NPAPI?

Дело в том, что NPAPI собираются выкинуть из Linux версии! http://citforum.ru/news/31436

Будете ли Вы сами его поддерживать?

Скажу больше, NPAPI выкинут из всех систем со временем. Такая работа постепенно ведется в рамках Chromium. 

А флеш? Его тоже выкинут со всех сайтов?

всё ведётся к новому хтмлю

Иван Маньков
29 июля 2014, 11:17

С радостью помогу в тестировании Я.Браузера на Linux!:-)

Жду :-)(+1)

Какие обновления сегодня?;-)

Просто HF. Исправление ошибок. 

oh да! наконец-то! (+1)

Блииииин.... Скорее бы....:-(

С момента последней новости про linux-версию прошло уже 4 месяца. Расскажите пожалуйста как продвигается стабилизация сборки. Мы очень-очень ждём.

Уже скоро. 

Обнадеживает)

Операционная система: Linux Linux Ваш браузер: YaBrowser 15.2 :) Ура, #yandex!

 

Еще нужна версия i686!

при установке из пакета yandex.rpm на RFR23 x86_64 требует libgcrypt и  libgcrypt11 которые в системе уже установлены и лежат в соответствующих папках /usr/lib и/uxr/lib64 версия пакетов 1.6.5 (х86_64 и i686) подскажите что ему требуется на самом деле по умолчанию.. какая версия пакетов ему нужна? или исправьте этот баг, в конце концов вложите необходимые пакеты в rpm  а не связывайте зависимостями.. спасибо